3DGE won't start

Are you experiencing a problem? Maybe you can't get your scripts to do what you need, or are frustrated by a feature you just can't seem to get working? Let us know about it here and we will try our best to help you out!
Posts: 1
Joined: Fri Mar 02, 2018 8:11 pm
Gender: None specified

3DGE won't start

Postby toh » Fri Mar 02, 2018 8:25 pm

First post here, sorry it's an issue I'm having. Please let me know what else I need to add.

I downloaded the latest Test 3 for Windows and tried to run it. I got the "msvcp140.dll not on system" but it's there in \system32. I downloaded the redist from Microsoft and "repaired" the installation but got the same error.

So, I copied the dll into the 3DGE directory and now I get this error:

3DGE.exe - Application Error
The application was unable to start correctly (0xc000007b). Click OK to close the application.

There is no debug.txt or edge2.log that I can find. Running Win7, there's doom2.wad in the same directory, and I haven't had any issue like this with other programs. I remember that I could never get older versions of 3dge to run either so I moved to other ports, but I just read about the new Wolf3d 3DGE mod that was released and wanted to try it.

This error happens if I double-click the exe, or run it from the command line. With dropping the EPK for the Wolf mod on it or not.

If I double-click the edgecrashreporter I get told that mfc140.dll is not installed which is also incorrect - that one's in \system32 as well.

Any thoughts on why this is happening?

Editing to add:

I ran DependencyWalker against 3DGE.exe to see what it is looking for that it couldn't find and it is looking or IEShims.dll which is seemed weird but, okay, I copied that into the directory as well. It is also apparently looking for the following which it can't find:


So now I'm sure this will mean something to someone but I am not that someone. Does this shed any light for anyone?

User avatar
Posts: 126
Joined: Sat Mar 14, 2015 3:10 pm
Gender: None specified

Re: 3DGE won't start

Postby RUNSABER » Fri Nov 30, 2018 10:58 am

Unfortunately bud, I've been having the same problems trying to run any newer versions and builds of 3DGE. Posted multiple debug and config files and the devs have not been responsive to my cause as well. It just gets overlooked. I dont want to think it is my machine, but at the same time it should be able to run it in x64.

My best advice to you is to use an older build of 3DGE (I use the TEST 2/3/4 builds) as they run with the least amount of hiccup and headache. It sounds counterintuitive considering the newer versions fix bugs, but at the same time - what's the point of fiddling with it if you cant run it? I hope someone can answer your questions. I would like to use newer versions as well.
- Public Repository for 3DGE 64.

Posts: 20
Joined: Wed Nov 08, 2017 11:51 pm
Gender: None specified

Re: 3DGE won't start

Postby so19 » Thu Dec 13, 2018 6:55 pm

I struck some issues with the latest build because I dropped the new files into a folder with an older build. This seemed to create a problem with dll files being in conflict

Once I remedied (put the new build into a new folder) - all good (Btw this is using on 3dge in Windows 10)

Return to “Support and Help”

Who is online

Users browsing this forum: No registered users and 1 guest